New 4k Monitors won't wake up from standby

Discussion in 'GLK-UC2X' started by ROBERT CARLSON MD, Jul 30, 2020.

  1. ROBERT CARLSON MD

    ROBERT CARLSON MD New Member

    Hi Ken / All,

    I have 2 GLK units which have been working fine for a few months. They both have all the latest updates for Windows 10 Pro, and the latest Intel DCH graphics driver 27.20.100.8336.

    I've been trying to upgrade my HP 1080p monitors to a 4K displays, but have run into a weird problem with each of the new units.

    I've tried 3 different 4K monitors, and none will wake up from standby /sleep mode. This includes 2 4K Acers, and most recently an "LG 32UK550-B 32 inch 4K UHD monitor with Radeon Freesync and HDR 10".

    All were set up using the HDMI port on the GLK and the cables that came with each monitor.

    At first, everything seems fine, but once the display goes to sleep it won't wake up properly. Activating the mouse or keyboard will cause the power LED on each of these monitors to come on, but after a few seconds the display reads "No Signal" and goes back to sleep. Clicking the mouse yet again has no effect.

    If the monitor is reset or unplugged / plugged again, the screen comes up normally.

    I've tried changing all the various settings on the monitors such as DFC, ECO settings, etc., without luck.

    I don't see any BIOS settings in the GLK that seem to pertain to this problem.

    Any suggestions?

    Thanks,

    -- R Carlson MD
     
  2. Support

    Support Administrator

    Are you suggesting the problem did not exist until the monitors were changed?
     
  3. ROBERT CARLSON MD

    ROBERT CARLSON MD New Member

    Yes, the original HP 1080p 24" display works perfectly, but each of the 3 different 4k displays I've tried will not come out of standby after the display times out. I have to plug and replug the power on the display to wake it up, and even then the previously open windows are all jammed up into the upper left corner of the display and each time have to be resized and repositioned.

    Since the first post, I've managed to get the LG 4K display working somewhat by turning Smart Energy Saving and Automatic Standby off. On waking, the previously open windows still get all jammed up in the top left corner, though. I normally have several complicated windows open 24 hours a day, so this is very annoying.

    I've tried turning off all the stuff related to power saving on the USB ports and everything else in Device Manager I can find. Sleep is set to never, and hybrid sleep is turned off. None of these seem to make any difference, though. Graphics driver is now 27.20.100.8476.

    Any ideas that I could try would be appreciated.

    Thanks,

    -- R Carlson MD
     
  4. Ken

    Ken Administrator Staff Member

    It sounds like a driver problem, my suggestion is that you uninstall and delete the driver completely, reboot the device. And then reinstall the latest DCH driver in fresh.

    By the way, is your BIOS the latest one we posted on forum (dated July 2019)?
    That consists of new video codes that is supposed to be compatible with DCH driver.
     
  5. ROBERT CARLSON MD

    ROBERT CARLSON MD New Member

    Yes, the BIOS is 5.13 dated 3-19-19.

    BTW the links in your post for the BIOS zip file and the DCH driver no longer work.

    Would there be any harm in disabling ACPI in the BIOS to prevent any unwanted standby modes?

    Thanks
     
  6. Support

    Support Administrator

    1.) 3-19-19 is NOT the latest BIOS:
    https://www.pepper-forum.com/index.php?threads/latest-bios-for-glk-uc2x.38/
    2.) You can get it from:
    https://downloadcenter.intel.com/download/29784
    Uninstall and delete the old/existing driver, reboot the PC before installing the new DCH driver.
    3.) No harm I believe, but shouldn't be related either.
     
  7. Support

    Support Administrator

    We have attempted 50 sleep/wakeup cycles with the latest bios and lastest graphics driver (27.20.100.8476) on a 4K monitor,
    no issues found.
     
  8. Support

    Support Administrator

    https://community.intel.com/t5/Intel-NUCs/HDMI-Monitor-Does-Not-Wake-From-Sleep/td-p/1189458

    I believe you are running into the exact same issue as above,
    it's a result of some bad combination of Windows version + driver version.

    Try updating the BIOS to the latest, uninstall the old driver and install the newest 8476 version.
     
  9. ROBERT CARLSON MD

    ROBERT CARLSON MD New Member

    Ken,

    That link for the BIOS download just links to the sticky note in the forum. The forum note has a link for BIOS download which only opens the Pepper Jobs main site. No downloads can be seen. That link is broken. I cannot download the BIOS zip file.

    I was able to get the latest Intel graphics driver, but will delete and reinstall it if I can download the BIOS update.

    BTW your forum software will not let "links" be sent in replies, even ones that you included.

    -- R Carlson MD
     
    Last edited: Aug 3, 2020 at 6:58 PM
  10. Ken

    Ken Administrator Staff Member

    Please send us a private message, we will send you the bios file by email before the link gets fixed.

    sorry about that.